For more then 3 years upgrade is not possible anymore - a new license is required. Contact support@maptiler.com.